Archives : January-2021

原文链接:「PHP」- 连接SQL Server数据库
文章分类:「04.High-Level_Programming_Languages:3.PHP_-_Hypertext_Preprocessor:3.Quick_Start_and_Tutorial:Connecting_to_a_Database:SQL_Server」
文章标识:「02b21fd1」

在PHP中,如果要连接SQL Server数据库,可以使用以下几种驱动:

Mssql
PDO_SQLSRV (Windows only)
PDO_ODBC
SQLSRV (Windows[……]

Read more

原文链接:「PHP」- 安装(CentOS)
文章分类:「04.High-Level_Programming_Languages:3.PHP_-_Hypertext_Preprocessor:2.Environment_Setup:on_CentOS」
文章标识:「c6c76253」

该部分笔记整理:在 CentOS 中,使用 YUM 源安装 PHP 环境(包括 PHP-FPM 环境)的方法。
PHP 5.6 on CentOS 7.4
How to Install PHP 5.6 on CentOS 7
在 CentOS 7.4 上,默认 PHP 5.4 版[……]

Read more

原文链接:「PHP」- 安装(Debian)
文章分类:「04.High-Level_Programming_Languages:3.PHP_-_Hypertext_Preprocessor:2.Environment_Setup:on_Debian」
文章标识:「460f6ce0」

PHP 7 on Debian GNU/Linux 8.11 (jessie)
PHP – Debian Wiki
方案一、使用第三方仓库安装(推荐)
建议参考以下文章进行安装: How to install PHP 7 on Debian Linux 8.7/7.x [jessie[……]

Read more

原文链接:「WordPress」- 升级 5.1.8 到 5.6 版本
文章分类:「07.Linux_as_a_Work_Environment:XDG_-_Documents:WordPress:2.Installing_and_Upgrading:Upgrade_5.1.8_to_5.6」
文章标识:「9facacee」

问题描述
我们需要将 WordPress 升级到最新版本(01/10/2021,WordPress 5.6)。
但是,通过后台升级会失败,经过排查是由于无法访问 wordpress.org 而导致失败。
该笔记将记录:在国内,如何升级 W[……]

Read more

原文链接:「Nginx, PHP-FPM」- NGINX 502 Bad Gateway
文章分类:「Web_Application_Server,_LB_and_HA:PHP-FPM:3.Problem_Solving_(how-to):NGINX_502_Bad_Gateway」
文章标识:「a92bad46」

问题描述
浏览器访问 URL 地址,页面显示 502 Bad Gateway 信息。
问题原因
导致该问题可能有多种原因:
第一种、服务未启动
没有启动 PHP-FPM 服务导致 Nginx 无法访问,因此返回 502 错误。
第二种[……]

Read more

原文链接:「PHP」- 安装Zend Guard Loader扩展
文章分类:「04.High-Level_Programming_Languages:3.PHP_-_Hypertext_Preprocessor:4.Packages_and_Build_Tools:3.Extensions_and_Libraries:How_to_Install_Zend_Guard_Loader」
文章标识:「9c946cf6」

内容简介
编码与混淆的解决方案,Zend Guard,而Zend Guard Loader是一个免费的运行时应用程序,它使PHP能够运行Zend Guard编码[……]

Read more