「Midori」- 安装

  CREATED BY JENKINSBOT

内容简介

如何在Linux下安装Midori浏览器。

相关链接

官方主页:http://midori-browser.org
项目地址:https://github.com/midori-browser/core

从源中安装

如果你的发行版中包含了Midori浏览器,那直接安装就好了:

#!/bin/sh

# Debian
apt-get install midori

源码编译

#!/bin/sh

################################################################################
# Debian
################################################################################
apt install cmake valac libwebkit2gtk-4.0-dev libgcr-3-dev libpeas-dev \
    libsqlite3-dev libjson-glib-dev libarchive-dev intltool libxml2-utils

mkdir _build
cd _build
cmake -DCMAKE_INSTALL_PREFIX=/usr/local ..

# 安装之前,可以运行一下
_build/midori

# 安装
make && make install

常见错误汇总

#1 valac not found

问题描述:
CMake Error at cmake/FindVala.cmake:9 (message):

valac not found – install Vala compiler or specify compiler name eg.

VALAC=valac-0.20

Call Stack (most recent call first):

CMakeLists.txt:41 (find_package)

解决办法:
# 安装valac编译器
valac: C# like language for the GObject system

#2

问题描述:
Checking for modules ‘libxml-2.0>=2.6;sqlite3>=3.6.19;gmodule-2.0;gio-2.0>=2.32.3;libsoup-gnome-2.4>=2.37.1’

解决办法:
检查提示中的依赖,检查其版本关系是否满足要求

参考文献

Wikipedia/Midori (web browser)
GitHub/midori-browser/core/Building from source