「Huawei VRP」- 配置 VLAN 环境

  CREATED BY JENKINSBOT

基础命令

创建 VLAN 信息:

[Huawei] vlan <vlan-id>

[Huawei] vlan batch <vlan-id_start> [ to <vlan-id_end>]

配置 Access 端口:

[Huawei-Interface] port link-type access
[Huawei-Interface] port default vlan <vlan-id>    # 配置默认 VLAN ID(PVID)

配置 Trunk 端口:

[Huawei-Interface] port link-type trunk
[Huawei-Interface] port trunk pvid vlan <vlan-id> # 配置默认 VLAN ID(PVID)
[Huawei-Interface] port trunk allow-pass vlan <vlan-id>

配置 Hybird 端口:

[Huawei-Interface] port link-type hybrid
[Huawei-Interface] port hybrid vlan <vlan-id> # 配置默认 VLAN ID(PVID)
[Huawei-Interface] port hybrid untagged vlan <vlan-id> # 在发送数据时,这些 VLAN 移除 TAG
[Huawei-Interface] port hybrid tagged   vlan <vlan-id> # 在发送数据时,这些 VLAN 添加 TAG

# 注意事项
# 1)对于 hybird 端口,没有 allow-pass 指令,
# 2)需要 tagged 与 untagged 指令,都是对从接口发出数据帧的处理;
# 3)但是能接收的数据,只能与 PVID 相同;
# 2)需要配置 pvid 及 tagged 与 untagged 属性;

VLAN 划分方法

基于 交换机端口 划分(极其常用)

不同的交换机端口,接入到不同 VLAN 中,是最常用的划分方法。

Access Port + Trunk Port


Hybrid Port


基于 IP Subnet 划分

基于 主机物理地址 划分(较少使用)

[Huawei] vlan 10
[Huawei-vlan] mac-vlan mac-address 0012-3456-7890

基于 协议 划分(较少使用)

基于 策略 划分(较少使用)

将上面的划分方法组合使用。

添加 VLAN(多设备)

S5700Svlanif为什么会down掉

在多个设备互联场景中,添加 VLAN 的大致步骤如下:

1)在各个设备上,创建 VLAN;
2)配置允许通过列表(allow-pass);
3)路由、通信:配置 VLAN 接口地址(在 交换机 或 路由器 中);

注意事项

接口 Vlanif 将出于 DOWN 状态

有两种情况可以使得 vlanif 能够正常 UP:
1)UP 的物理接口被划入 VLAN:
—- port link-type access; port default vlan 30;
—- port hybird tagged vlan 30;
2)有 UP 的 Trunk 允许该 VLAN 通过。