「Groovy」- Unable to load extension class

  CREATED BY JENKINSBOT

问题描述

在执行 Groovy 脚本时,每次都会产生如下错误:

# groovy --version
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=on
Feb 12, 2021 2:35:37 PM org.codehaus.groovy.runtime.m12n.MetaInfExtensionModule newModule
WARNING: Module [groovy-datetime] - Unable to load extension class [org.apache.groovy.datetime.extensions.DateTimeExtensions]
Feb 12, 2021 2:35:37 PM org.codehaus.groovy.runtime.m12n.MetaInfExtensionModule newModule
WARNING: Module [groovy-datetime] - Unable to load extension class [org.apache.groovy.datetime.extensions.DateTimeStaticExtensions]
Groovy Version: 2.5.7 JVM: 1.7.0_79 Vendor: Oracle Corporation OS: Linux

问题原因

因为 JDK 版本较旧,没有该方法,所以导致出现上述错误。

解决方案

将 JDK 版本更新到 8 即可解决该问题:

# groovy -version
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=on
Groovy Version: 2.5.7 JVM: 1.8.0_73 Vendor: Oracle Corporation OS: Linux

参考文献

apache – Groovy – groovy-datetime module – Stack Overflow