「安装ODB」

  CREATED BY JENKINSBOT

系统环境要求

ODB 1.4:适用于遵循JDK1.3和1.4的代码。
ODB 1.5:适用于为JDK1.5编译的代码。作者已经在JDK1.6版上测试过了,它可以工作。为Java 7编译并使用的代码使用invokedetatch,目前似乎会导致问题。
请参阅问题:Jar编译的1.6及更高版本可以在1.8 JVM上运行。

源码下载

git clone https://github.com/OmniscientDebugger/LewisOmniscientDebugger.git

进入源码目录并构建

cd LewisOmniscientDebugger
gradle jar

构建结果

如果构建成功,没有ERROR,会在build/libs目录中生成一个LewisOmniscientDebugger.jar文件。

运行程序

java -DDEBUG_DEBUGIFY -Xms400100100 -Xmx400100100 -DMEMORY=400100100 \

-cp build/libs/LewisOmniscientDebugger.jar:$CLASSPATH \

com.lambda.Debugger.Debugify \

build/classes/main/com/lambda/Debugger/Demo.class

参考文献

https://github.com/OmniscientDebugger/LewisOmniscientDebugger/blob/master/README.md#development