「Emacs」- 安装(Debian、Ubuntu、CentOS、源码编译)

  CREATED BY JENKINSBOT

问题描述

该笔记将记录:在各平台中,如何安装 GNU Emacs 编辑器,以及部分常见问题处理方法。

Debian-based Linux Distribution(Debian、Ubuntu、Kali Linux)

apt-get install -y emacs emacs-bin-common emacs-common emacs-el emacs-gtk

# 无图形化界面版本
apt-get install emacs24-nox

安装最新版本

EmacsWiki: Emacs For Linux
EmacsWiki: App Image

我们需要安装 Emacs 最新版,我们想体验 Emacs 27 的 Tab Bars 功能(事实证明,对于我们来说这个功能相当棒)

解决方案

这里有两种方法可以获取最新版本:
1)使用 AppImage 镜像;
2)使用源码编译安装最新版本;

方法一、使用 AppImage 镜像(推荐)

1)到 Releases · probonopd/Emacs.AppImage 下载 AppImage 文件;
2)授予执行权限:chmod u+x Emacs-xxxxx.AppImage
3)运行 AppImage 文件:./Emacs-xxxxx.AppImage

方法二、源码编译安装

源码编译的方法不再展开(因为涉及很多细节,内容有冗长),参考「编译安装」部分。

编译安装

BLFS/Emacs-25.1-rc2
BLFS/Emacs-27.1

如果编译 Emacs 只是为了体验新版本,建议使用 AppImage 程序,参考「安装最新版本」笔记。

第一步、源码下载

镜像服务器地址列表:https://www.gnu.org/prep/ftp
清华镜像地址:https://mirrors.tuna.tsinghua.edu.cn/gnu/emacs

第二步、编译并安装

# Without GUI
./configure \
	--prefix=/usr \
	--localstatedir=/var \
	--without-x

# With GUI
apt-get install libgtk2.0-dev libxpm-dev libgif-dev

./configure \
	--prefix=/usr \
	--localstatedir=/var \
	--with-x-toolkit=gtk2
	
# 参考 BLFS/Emacs-25.1-rc2 页面,获取详细构建说明
# http://www.linuxfromscratch.org/blfs/view/7.10/postlfs/emacs.html

# 参考 BLFS/Emacs-27.1 页面,获取详细编译说明
# http://www.linuxfromscratch.org/blfs/view/svn/postlfs/emacs.html 

第三步、运行 Emacs 程序

/usr/bin/emacs

# 终端模式运行
/usr/bin/emacs -nw

编译错误:[bootstrap-emacs] Segmentation fault

compiling – How to compile GNU Emacs 25.1 on 16.10 – Ask Ubuntu

问题描述:在执行 make 命令时,出现的错误。

解决方案:在配置时,不使用PIE:

CFLAGS=-no-pie ./configure

安装的可执行程序

ctags
生成标记文件,文件中记录的是:源码之间的交叉引用关系。
就是IDE里经常使用的那个:按住Ctrl,然后点击函数名的功能中使用的标记文件

etags
生成标记文件,文件中记录的是:源码之间的交叉引用关系。
就是IDE里经常使用的那个:按住Ctrl,然后点击函数名的功能中使用的标记文件

ebrowse
允许从emacs中浏览C++类层次结构。

emacs
Emacs编辑器

emacsclient
将emacs会话附加到已经运行的emacsserver实例上。

grep-changelog
打印符合各种条件的ChangeLog中的条目。

参考文献

BLFS / Emacs-25.1-rc2