「Eclipse」- 指定运行 Eclipse 的 JVM 版本(Linux)

  CREATED BY JENKINSBOT

问题描述

在运行 Eclipse 2020-09 版本时,需要使用 JDK 11 以上。

我们不希望修改系统默认的 JDK 版本,而是为 Eclipse 使用特定 JDK 版本。

该笔记将记录:如何设置用于 Eclipse 的特定 JDK 版本。

解决方法

修改 eclipse.ini 配置,添加如下配置行:

-vm
/opt/openjdk/openjdk-15.0.1/bin/java
...

我们将该配置添加到 eclipse.ini 的最开始,然后启动 Eclipse 成功。

参考文献

eclipse.ini – Eclipsepedia / Specifying the JVM