「Supervisor」- 安装

  CREATED BY JENKINSBOT

依赖环境

Supervisor is intended to work on Python 3 version 3.4 or later and on Python 2 version 2.7.

注意事项

如果从发行版的仓库中安装,那么安装的 Supervisor 版本会落后于官方版本。比如 CentOS 6.5 仓库中只包含 Supervisor 2.1 版本。

如果从发行版安装 Supervisor 是为了自带的服务管理脚本,那大可不必:
GitHub/Supervisor/initscripts
How to automatically start supervisord on Linux (Ubuntu)

Supervisor 2.1 on CentOS 6.5

Supervisor/Installing a Distribution Package

yum install supervisor-2.1
service supervisord start
chkconfig supervisord on

参考文献

Supervisor 4.0/Introduction